Не работает soursebans (серверы за NAT)

Тема в разделе "SourceBans", создана пользователем Evkval, 10 авг 2014.

  1. Evkval

    Evkval

    Сообщения:
    42
    Симпатии:
    1
    Добрый день! Парни помогите решить проблему. Серверы у меня дома за роутером. Операционка ubuntu 12.04 x64 Игровые порты 270.. проброшены игроки заходят все норм. Сурсбан установлен на хостинге.

    Проблема следующая, не добавляются админы в файл admins.cfg. в строке запуска установлен параметр +ip 0.0.0.0. Команда status показывает
    udp/ip : 0.0.0.0:27023 [ public 178.140.239.82:27023 ] . как бы на первый взгляд все норм.

    Eсли запускать с параметром +ip 178.140.239.82:27023 . Сервер не запускается и падает с ошибкой.


    Проблема именно с настройками сети, так как пробовал ставить на VPS все шикарно отрабатывает с теми же настройками операционки и игрового сервера. Но там у меня сервер запускается с параметром +ip внешний ip. Как я понял это требование должно выполняться, иначе не работает корректно сурсбан.
     
  2. Danyas

    Danyas Спасибо, браток © yand3xmail Модератор

    Сообщения:
    1.729
    Симпатии:
    461
    С внутренним IP запускай
     
  3. Evkval

    Evkval

    Сообщения:
    42
    Симпатии:
    1
    Надо было добавить в конфиг soursbans.cfg serverID. Может кому пригодиться
     
  4. Hejter

    Hejter Mapper Source Engine

    Сообщения:
    1.771
    Симпатии:
    259
    Оффтоп
     
  5. Petrovich

    Petrovich

    Сообщения:
    188
    Симпатии:
    44
    С каким +ip запускается сервер - разницы нет. Главное, чтоб не было проблем в передаче данных между хостерами. Базы данных некоторых хостеров закрыты и не пропускают внешние данные.