Ошибка с MySQL...

Тема в разделе "Общие вопросы", создана пользователем dearring, 29 янв 2013.

  1. dearring

    dearring

    Сообщения:
    47
    Симпатии:
    12
    Привет всем!

    Собственно, ошибки, помогите поправить!


    Код:
    "Databases"
    {
    	"driver_default"		"mysql"
    	
    	// When specifying "host", you may use an IP address, a hostname, or a socket file path
    
    		"default"
    	{
    		"driver"			"sqlite"
    		"host"				"localhost"
    		"database"			"sourcemod"
    		"user"				"root"
    		"pass"				""
    		//"timeout"			"0"
    		//"port"			"0"
    	}
    	
    	"storage-local"
    	{
    		"driver"			"sqlite"
    		"database"			"sourcemod-local"
    	}
    
    	"clientprefs"
    	{
    		"driver"			"sqlite"
    		"host"				"localhost"
    		"database"			"clientprefs-sqlite"
    		"user"				"root"
    		"pass"				""
    		//"timeout"			"0"
    		//"port"			"0"
    	}
    	
    	"ctbans"
        {
            "driver"            "mysql"
            "host"            "xxx"
            "database"            "xxx"
            "user"            "xxx"
            "pass"            "xxx"
            //"timeout"            "0"
            "port"            "3306"
        }
    	
    	"sourcebans"
    	{
    		"driver"			"mysql"
    		"host"				"xxx"
    		"database"			"xxx"
    		"user"				"xxx"
    		"pass"				"xxx"
    		//"timeout"			"0"
            "port"              "3306"
    	}
    	
    	"rankme"
    	{
    		"driver"			"mysql"
    		"host"				"xxx"
    		"database"			"xxx"
    		"user"				"xxx"
    		"pass"				"xxx"
    		//"timeout"			"0"
    		"port"				"3306"
    	}
    }
    

    Код:
    L 01/29/2013 - 19:13:15: SourceMod error session started
    L 01/29/2013 - 19:13:15: Info (map "ba_jail_electric_vip_v3") (file "errors_20130129.log")
    L 01/29/2013 - 19:13:15: [admin-sql-prefetch.smx] Could not connect to database "default": Configuration "default" not found
    L 01/29/2013 - 19:13:15: [admin-sql-prefetch.smx] Could not connect to database "default": Configuration "default" not found
    L 01/29/2013 - 19:13:15: [admin-sql-prefetch.smx] Could not connect to database "default": Configuration "default" not found

    До этого тоже выскакивала эта ошибка, но Баны и др. плагины прекрасно работали...
    Сейчас ни Веб часть SourceBans (Ошибка - 504 Gateway Time-out), ни другие плагины, которые работают с MySQL не работают. Хотя базы данных вроде работают.

    P.S. Заранее спасибо.
     
  2. ☆★☆БАТЯ☆★☆™

    ☆★☆БАТЯ☆★☆™

    Сообщения:
    2.585
    Симпатии:
    1.341
    В первом вместо sqlite поставь default
     
    dearring нравится это.
  3. dearring

    dearring

    Сообщения:
    47
    Симпатии:
    12
    Код:
    		"default"
    	{
    		"driver"			"default"
    		"host"				"localhost"
    		"database"			"sourcemod"
    		"user"				"root"
    		"pass"				""
    		//"timeout"			"0"
    		//"port"			"0"
    	}
    
    Так? Я и так тестил, все равно.
     
  4. dearring

    dearring

    Сообщения:
    47
    Симпатии:
    12
    UPD: Базы данных на 1 хостинге, сервер на другом, веб-часть SB на третьем.
    Может ли быть в этом проблема?
     
  5. SaInT.P

    SaInT.P

    Сообщения:
    1.270
    Симпатии:
    237
    нет,есле все указать правильно)
     
  6. dearring

    dearring

    Сообщения:
    47
    Симпатии:
    12
    Указано все верно, раньше работало. Видимо что-то с хостингом баз данных.