Высокий var, низкий фпс (cs:go)

Тема в разделе "Всякое", создана пользователем neploho, 26 июл 2015.

  1. neploho

    neploho

    Сообщения:
    21
    Симпатии:
    0
    Ребята, столкнулся со следующей проблемой. Есть собственные выделенные серверы cs:go. Железо под сервер нормальное (i5, 32gb), при запущенных 6 серверах (60+ слотов) нагружается под 40% проца и совсем немного оперы.

    Так вот - проблема в том, что я совершенно не могу играть на своем компьютере (i7, gtx760, 16гб) на своих же серверах.

    Проблема на видео:

    http://www.youtube.com/watch?v=ZcxX-ysMZcM&feature=youtu.be

    Первые минут 5 все нормально. Потом резко повышается вар и падает фпс. Иногда может через карту (минут 30), но практически постоянно вот уже как месяц. На ММ и пабликах валв такого нет. Иногда подскочит вар, но это раз в 10-15 минут и больше похоже на обычный лаг.

    Мониторинг игрового компьютера ничего не дает. Нагрузки на процессор \ оперу \ видеокарту нет. У других игроков (даже с других городов) такой проблемы нет. Сервер, как я уже говорил, практически не напрягается. В логах роутера все чисто, никаких потерь пакетов или что-то подобного. В других играх подобного нет. ВСе идет гладко и без тормозов.

    Уже просто отчаялся. Если кто-то сталкивался с подобным, пожалуйста расскажите как вам удалось решить проблему.
     
  2. vaxa

    vaxa Rock Rulet!

    Сообщения:
    859
    Симпатии:
    102
    А ты попробуй на linux запустить сервера,и посмотри результат....
     
  3. neploho

    neploho

    Сообщения:
    21
    Симпатии:
    0
    На сервере и так линукс, debian 8 стоит. Играют люди с других городов, с разным пингом. У меня все лагает, двигаться не могу. Другие играют нормально. При этом даже если выйти в меню, то вар остается на том же уровне и даже мышкой водить тяжело.
     
  4. pentaxist

    pentaxist

    Сообщения:
    119
    Симпатии:
    18
    Дрова обнови, в крайнем случае винду переустанови.
    Если у других все нормально значит проблема в твоей железке
     
  5. Саша Шеин

    Саша Шеин

    Сообщения:
    1.259
    Симпатии:
    191
    Может у тебя инет слабый?
    P.S. Мне в полне хватает 10 мб/с итернета для сидения в консольке сервера. играния на нёмже и сидения в интернете + видюха ♥♥♥♥♥ и оперы всего 4 gb
     
  6. neploho

    neploho

    Сообщения:
    21
    Симпатии:
    0
    Тогда почему такой проблемы не наблюдается на валв пабликах и ММ? Там просто пинг до 50-60 поднимается, но var в порядке. Т.е. проблемы с интернетом вроде нет. Железо - возможно. Попробую винду переставить... Но это видео я записываю в 720p и 60fps и проблем нет. Все тянет прекрасно.

    Да и проблема какая-то странная. Как снежный ком. Играешь минут 10-15 с var 0.5, потом просто нчачинает расти до 2-3, потом 20-30, лютые фризы и совершенно нереально играть. Рестартишь кс, заходишь в ММ и хоть весь день бегай - такого не будет.

    На сервере пробовал уменьшать количество слотов, выключать серверы - ничего не помогает.

    Буду пробовать менять что-то в своей системе, хотя не могу понять логики. Тут не работает, там все ок...
     
    Последнее редактирование: 26 июл 2015
  7. Саша Шеин

    Саша Шеин

    Сообщения:
    1.259
    Симпатии:
    191
    Попообуй на других серверах поиграть. Не valve

    Добавлено через 1 минуту
    и не своих

    Может тикрейт поменять попробуй
     
    Последнее редактирование: 26 июл 2015
  8. Hejter

    Hejter Mapper Source Engine

    Сообщения:
    1.771
    Симпатии:
    259
    Обнови дрова на видеокарте. У меня ноутбук очень слабый, csgo тянет на минималках, была такая проблема, обновил драйвера и вроде все встало. Вот так лагает как на видео, очень редко.
     
  9. Danyas

    Danyas Спасибо, браток © yand3xmail Модератор

    Сообщения:
    1.715
    Симпатии:
    452
    Поставь какой-то расширенный Process Monitor и посмотри чего не хватает
     
  10. neploho

    neploho

    Сообщения:
    21
    Симпатии:
    0
    Почитал. Тема интересная. Но если бы в этом было дело, то все клиенты бы жаловались на подобное. Моя нагрузка на серверное железо:

    [​IMG]
    [​IMG]

    Спросил у знакомых, кто у меня играет, но так как время позднее ответил только один:

    [​IMG]

    Ну и просто спрашивал у играющих в момент особо сильных лагов у меня, есть ли у них подобное - ни у кого не было. Т.е. сервер \ роутер \ интернет в порядке.

    Зашел на сервер, что у тебя в подписи. Было около 5 человек со мной. Вар скакал до 2-3, перезашел на другой сервер и там просто вар встал на 70+, кс умерла и я не смог даже видео записать.

    Попробовал второй раз. И вот тут эффект "снежного кома" виден просто отлично. Начинаю с 0.5 и под конец доходит до неприличного. Самый пик выпал ( как ни странно) на паблик валв сервер (хотя прежде такого никогда не было). К 10 минуте начало подкидывать до 10, дальше был валв паблик, там вообще нереально. Забыл сделать скрин состояния системы, но проц загружался на 13 процентов, температура на видеокарте было около 55 градусов.

    http://www.youtube.com/watch?v=4ldfBzR3ggo

    Тикрейт имеется ввиду на сервере? Там я уже что только не делал. Уменьшал слоты, выключал отдельные серверы, т.е. по сумме слотов сильное шло снижение - у меня проблема осталась. Менял тики на 64 и 128 - нифига.

    Драйвера самые последние

    [​IMG]

    Все же склоняюсь к проблеме на своем компе (попробую переустановить винду) или в цепочке сервер>роутер>я. Проблема появилась просто из ниоткуда, никогда подобного не было. Серверами занялся около года назад, косяки полезли месяца с полтора назад.

    Пиариться никак не хочу, но на видео видно мою закладку избранного и найти мои сервера можно по тегу в начале названия серверов. Быть может кто-то попробует поиграть и скажет - есть ли у него похожие симптомы.

    Добавлено через 25 минут
    Поставил, сделал фильтр на процесс ксго и данные по сети. Потерь вообще никаких нет. Т.е. дело не в интернете. Остальные фильтры показывают отсутствие всяких png и прочей лабуды. Нужен както-то более точный фильтр, что бы понять что искать.
     
    Последнее редактирование: 27 июл 2015
  11. BatyaMedic

    BatyaMedic Ньюсмейкер

    Сообщения:
    769
    Симпатии:
    123
    Про клиентский тикрейт говорят вроде.
     
  12. Danyas

    Danyas Спасибо, браток © yand3xmail Модератор

    Сообщения:
    1.715
    Симпатии:
    452
    Переустанови игру с удалением всех конфигов, как вариант
     
  13. Саша Шеин

    Саша Шеин

    Сообщения:
    1.259
    Симпатии:
    191
    Я про серверный.
     
  14. The Night Fury

    The Night Fury Администратор

    Сообщения:
    1.221
    Симпатии:
    914
    Есть предположение, что проблема с хардом. Дай характеристики ПК.
    Желательно развернутую информацию по частотам/скоростям. Да и вообще развернутую информацию о железе.
    Можешь попробовать мониторить шины хоть через стандартный диспетчер. В моменты тормозов, по идее, у тебя будет заметная перегрузка на графике.
     
  15. neploho

    neploho

    Сообщения:
    21
    Симпатии:
    0
    Да, я думал об этом. Но винт относительно новый, другие игрушки с него прекрасно играются. WoW, Diablo 3 - без проблем все идет.

    [​IMG]
    Непосредственно сам винт, на котором стоит кс:
    [​IMG]

    По вашему совету включил мониторинг винта в диспетчере задач, но ничего необычного не увидел. Отыграл 2 карты без особых лагов.

    Буду ждать когда опять волна найдет и тогда уже смотреть.
     
  16. The Night Fury

    The Night Fury Администратор

    Сообщения:
    1.221
    Симпатии:
    914
    Думаю, что дело в харде. Возможно, есть смысл поставить свап на безлимитный режим (как для системы, так и для диска с приложением). Возможно, что может быть проблема с охлаждением CPG/GPU, хотя это маловероятно. Если есть возможность, то попробуй поставить другой хард и шину.
     
  17. neploho

    neploho

    Сообщения:
    21
    Симпатии:
    0
    Свап и так по выбору системы, хотя с 16 гб оперы он врятли вообще нужен. На скринах видна температура матери, проца и остального. Там все весьма прохладно. Но сегодня на удивление поиграл нормально, никаких проблем не было.